0 评论

0 收藏

分享

node和npm版本太高导致项目无法正常安装依赖以及正常运行的解决办法

https://doc.youyacao.com/88/2098

node和npm版本太高导致项目无法正常安装依赖以及正常运行的解决办法:如何使用nvm对node和npm版本进行切换和管理

1,点击下载 nvm 并且安装
进入nvm的github:
GitHub - coreybutler/nvm-windows: A node.js version management utility for Windows. Ironically written in Go.
这里下载发行版,Releases · coreybutler/nvm-windows · GitHub
找到 这个 nvm-setup.zip下载 直接运行安装,不要到c盘, 这里设置要管理切换的node的路劲,建议也是d盘,另外会直接检测
到已经安装的node 并且询问你是否需要把现在已安装版本node纳入控制,点确定即可。
执行
nvm -v
能提示版本号证明安装成功,用cmd执行才有效,你用外部终端可能不行,
2,安装指定node版本
我的本机node20 太高了,导致优雅草蜻蜓系统无法打包
可以开始安装对应的node版本 比如我们优雅草蜻蜓系统的要求为:
node-v v14.21.3npm-v 6.14.18
那么执行命令:
nvm install v14.21.3 //安装node版本3,切换node版本nvm use 版本号  //切换版本号
需要切换使用:
nvm use v14.21.3
执行后提示: Now using node v14.21.3 (64-bit)即可成功
常用nvm指令nvm uninstall 版本号 //卸载node版本nvm off // 禁用node.js版本管理(不卸载任何东西)nvm on // 启用node.js版本管理nvm -v // 显示nvm版本nvm install stable // 安装最新稳定版nvm current // 显示当前使用中的nvm版本​重新开始安装依赖同理可证切换npm版本
我们仔细观察可发现,当我们下载指定node版本的时候就会指定下载npm的版本
C:\Users\Administrator>nvm install v14.21.3Downloading node.js version 14.21.3 (64-bit)...CompleteCreating D:\soft\nvm\tempDownloading npm version 6.14.18... CompleteInstalling npm v6.14.18...Installation complete. If you want to use this version, typenvm use 14.21.3




优雅草论坛2022年8月11日大改,优雅草论坛变回只服务于客户的提问交流论坛,详情查看优雅草8月11日大改,原因详情查优雅草外卖乐关闭

回复

举报 使用道具

全部回复
暂无回帖,快来参与回复吧
fenghuang
超级版主
主题 21
回复 0
粉丝 0
快速回复 返回顶部 返回列表